Currently broken. Updates coming?

Help to solve your PlugPlayer related problems

Currently broken. Updates coming?

Postby jja » Fri Jun 02, 2017 10:35 am


Your application would be very good if it were not broken.

I managed to use it in the last version of MacOS, but then I hit a problem from which I cannot recover.

I did do a search. It found what I wanted, so good this far. But after that the system decided to filter out everything that did not fulfil the search criteria.
I cleared the search field. I even reinstalled the program. No impact.

I can do a new search, which works ok. But I cannot go back to the situation in which there is no filtering going on.

I would really appreciate if you could update/fix the app. It would be a good one if it worked.
Posts: 2
Joined: Fri Jun 02, 2017 10:20 am

Re: Currently broken. Updates coming?

Postby abramsh » Sun Jun 04, 2017 7:21 pm

I'm not sure I completely understand the issue you are facing. It sounds like you are saying the media tree has only filtered results even after reinstalling PlugPlayer. I've tried to reproduce this and I can't, plus it's hard to imagine how PlugPlayer could do that since it does not store any information related to searches, especially after re-installing it. (To make sure everything is removed, after you uninstall it, make sure to remove the folder "~/Library/Containers/com.plugplayer.plugplayer")

Assuming I understand the issue you are facing: Perhaps it's your server that is causing the issue. The way UPnP filtering works is that the client (PlugPlayer) sends a request for a folder and specifies the filter criteria, the server then returns the results. All the filtering is done on the server and PlugPlayer just uses what is in the search field when making the request. If you've cleared the field and even gone the extra step of re-installing PlugPlayer and you're still seeing filtered results from a previous search that would indicate that either a) PlugPlayer is sending the same criteria (which seems unlikely since it wouldn't have that information), or b) The server is caching an old result for some reason (odd, but possible).

We haven't seen an issue with searches before, but we have seen other problems where the server "remembers" PlugPlayer in some odd way. For example, situations where Twonky would incorrectly guess what type of device PlugPlayer is, and then "remember" that guess causing some types of files to not show up in PlugPlayer. The fix was go to into the Twonky settings and reset them.

Hope that helps.
Posts: 2291
Joined: Tue Jul 07, 2009 7:40 pm

Re: Currently broken. Updates coming?

Postby jja » Sun Jun 04, 2017 11:13 pm

Thank you for your answer. The missing part was the name of the directory to remove for a complete reinstall.

I was able to solve the issue by the following steps:
1. Remove PlugPlayer.
2. Remove the directory you mentioned.
3. Reboot the UPnP server (Asset-UPnP on Ubuntu 14.04 LTS linux)
4. Rebuild the UPnP server's database
5. Reinstall PlugPlayer

And everything works fine.

But I have been able to reproduce the issue. If the following conditions hold when doing a search, the the problem reappears
- Asset-UPnP is updating the database when you do the search.
- Unison is running actively on the server (creating an incremental backup of the music files).

It could be that Asset-UPnP gets somewhat confused in such a case. My server is a very low-end machine, and I would not
be surprised that some timeouts happen with such a load. I'll report the issue to the creators of Asset-UPnP also.

The strange thing is that the problem does not get solved without complete database recreation on the server *and* complete reinstall
of PlugPlayer. I would assume that either should be sufficient, but no. I have to do both.

But in any case, the issue is solved. I have found the situation in which it appears and know how to solve it. Solving is easy enough
not to be a real problem

With the issue solved, PlugPlayer works very well. Thank you.
Posts: 2
Joined: Fri Jun 02, 2017 10:20 am

Return to Problems

Who is online

Users browsing this forum: No registered users and 2 guests